Hi all,
I used OpenMC to do the deplete calculation.I ran into a problem when I tried to get the number of U235 atoms.Here are some screenshots of the problem.I’m sorry if my problems are stupid.
thanks in advance,
2021-07-23 17-08-54 的屏幕截图

@HaoPF, Hi

I encountered the same problem few days ago when i was testing the depletion calculation, but in my case the error was in the misidentification of the right id when i was calling the depletion results (i naively used the same id as in the openmc example, i.e ‘1’), and once i checked it in Materials.xml file, my depleteable material was set to be with id=‘4’ and once changed everything went well. Here in your case, i see that, despite you are using the right id of your depletable material, you got an error about the id material (KeyError : ‘1’) and i compared both materials.xml files (yours and mine) and the only difference is the density definition, where you are using weight density (wo) when i’m using atomic one (ao) in my file. I’m not sure that could be the source of the problem, but the report in error message is pointing to some concentration calculation in the corresponding module !!

@HaoPF That does look strange. Do you have a model and/or depletion results file that you’re able to share so that I can try to look into it further?

@bentridisalah Sorry for the late reply.As you said, I used the correct material ID but still got the error.I’ll try using ‘ao’ to define density.Thank you very much for your reply.

@bentridisalah I used ‘ao’ to define the density and was able to get the number of U235.Thank you very much for your advice.

You are very welcome. I’m pleased that you could fix the problem.