Segmentation fault at the end of any simulation

Hi there,
I get a segmentation fault error at the end of any simulation.
The summary, statepoint and tallies.out files are all written correctly.
I tried to debug the problem and here below you can see the screenshot of what I obtained.

Do you have an idea of what can be the issue?
Let me know if more information is necessary.


Hi there,

I update my Linux Mint to the latest version (20.2), downloaded and compiled again the code.
Nevertheless, the problem is still there as you can see from the screenshot here below.


Hi @valerio69. Thanks for reporting this problem you’re seeing. Are you able to share your model or at least a simplified version that demonstrates the segfault?

Hi @paulromano.

it seems that it does not really matter the used model. I’m always getting the segfault error at the end of any simulation.

Here below you can see the screenshot of what I get running the pincell example

Here below the xml, statepoint and summary files available in the folder at the end of the simulation shown above.
geometry.xml (905 Bytes)
materials.xml (2.4 KB)
settings.xml (511 Bytes)
tallies.xml (10.1 KB)
statepoint.100.h5 (613.8 KB)
summary.h5 (46.6 KB)

I do not know if it can help but here you can see the info of my system

Last night I built from the sources mpich-3.4.2 and hdf5-1.12.1.
I will now try to build openmc using these new versions to see if the segfault will still be present.

I’ll let you know.


The problem has been SOLVED!
There was nothing bad with openmc, it was related to the LD_LIBRARY_PATH variable of my system.

I found it running the openmc created with the mpich and hdf5 built from sources. The segfault error was still there but I got more information about it. Thus, I saw that there was a reference to the file
which is actually a link to the file on the same folder.

Looking at the LD_LIBRARY_PATH variable, I saw that the path /opt/nvidia/hpc_sdk/Linux_x86_64/21.5/compilers/lib/ was at the beginning of the list (…my fault, I put it there when I installed the NVIDIA HPC-SDK). Moving it at the end solved the problem.

Now the segfault is gone! :slightly_smiling_face:


1 Like