Running into errors when running 'make'

Hi all, I am running into an error when trying to compile OpenMC. I can successfully run the ‘cmake …’ command per the install documentation, however, when I get to the ‘make’ command, I run into the following:

make[2]: *** [CMakeFiles/libopenmc.dir/src/bank.cpp.o] Error 1
make[1]: *** [CMakeFiles/libopenmc.dir/all] Error 2
make: *** [all] Error 2

I checked the /build/CMakeFiles/libopenmc.dir/ and do not see the ‘all’ file/dir. In the /src dir, there is no ‘bank.cpp.o’ file/dir either.

I used git clone to get the root directory of OpenMC. Any help with this would be appreciated!

Thank you.

@n0xn4me welcome to the community! Sorry to hear you’re having trouble compiling. Can you provide a little more information? To start with – what operating system are you on, and what compiler are you using?

Hi Paul, thanks for the quick response. Here are the steps I did:

git clone --recurse-submodules GitHub - openmc-dev/openmc: OpenMC Monte Carlo Code
cd openmc
git checkout master
mkdir build && cd build
cmake … (using cmake 3.16.2)
make (this is where I run into the error)

OS: RHEL 7.9

@n0xn4me sorry for the delay. Were you ever able to get a build successfully working? If you’re able to post the full output from cmake/make, that might help narrow things down.