Command 'njoy' returned non-zero exit status 1

Hello, I’m having an error when I run the test suite relating to njoy. When I run the test suite, three of the unit tests raise the following error from the run function:

 E               subprocess.CalledProcessError: Command 'njoy' returned non-zero exit status 1.
../openmc/data/ CalledProcessError

This may be related to how I have njoy set up. I have njoy21 intstalled, but the test suite seemed to be having trouble finding the executable file. The executable is called njoy21, so the test suite was skipping the tests that required njoy. So, I made a new symbolic link in the same folder called njoy that links to njoy21. Now both commands open njoy on the command line and the test suite recognizes that njoy is installed, but a few of the njoy-related tests raise this error.

Could anyone help me figure out what is causing this problem?


Hey @kevinm387. NJOY21 doesn’t seem to work for all cases for us, especially with respect to processing thermal scattering data. I’m working through some of the issues, one of which is a sort-of bug on our part (now fixed in this pull request) and one of which is a bug in a dependency of NJOY21. I’d recommend sticking to NJOY2016 for now if you can. Based on my discussions with the NJOY folks, NJOY21 is not quite ready for prime time. Nevertheless, I’ll try to post an update here when we get to a point where all our tests work with NJOY21.

Ok thanks @paulromano, I really appreciate the info.